Cobra 25 low receive

Need some help with a radio mod? Pop in and ask away.
Post Reply Previous topicNext topic
User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 420
Joined: June 26th, 2011, 6:05 pm
Age: 49
11

Cobra 25 low receive

#409116

Post by smoke blower »

Cobra 25 has very low receive and the audio chip gets very hot I checked a few caps any ideas what it could be I also put in a new audio chip and same thing


Post Merge Complete

Added 1 day 38 minutes 6 seconds after previous.
The radio keys up but modulation is very faint and the receive is real low and audio chip gets so hot you can't touch it. Some help would be greatly appreciated







Donate to CBRT
User avatar
terryj
Donor
Donor
Posts: 23
Joined: April 19th, 2013, 11:17 am
Age: 72
9

#409125

Post by terryj »

smoke blower wrote: June 22nd, 2022, 4:54 pm Cobra 25 has very low receive and the audio chip gets very hot I checked a few caps any ideas what it could be I also put in a new audio chip and same thing


Post Merge Complete

Added 1 day 38 minutes 6 seconds after previous.
The radio keys up but modulation is very faint and the receive is real low and audio chip gets so hot you can't touch it. Some help would be greatly appreciated
Both the modulation and the receive audio are processed by the TA7222P (IC1). If this IC is getting very hot then check the associated components to this IC. Check the caps in the output circuit, C61 could be shorted to ground, but check caps C63, C62, C67 and C168. Check for the correct voltages on IC1.
If you don't have a schematic you can get one from here: [Please login or register to view this link]







Donate to CBRT
User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 420
Joined: June 26th, 2011, 6:05 pm
Age: 49
11

#409128

Post by smoke blower »

I will check those out and see what I find I already checked a few around the audio chip . Thank you for helping I will let you know when I get these checked y


Post Merge Complete

Added 8 hours 15 minutes 58 seconds after previous.
I can't find c62 or c168


Post Merge Complete

Added 15 hours 41 minutes 26 seconds after previous.
I have looked the schematic over and the parts layout and I am having a very hard time finding c62 or c168


Post Merge Complete

Added 9 hours 54 minutes 58 seconds after previous.
I have been over this board serval times I don't see a C72 or C168


Post Merge Complete

Added 5 hours 11 minutes 20 seconds after previous.
Man it would be nice to have someone help me with this . This is why I haven't donated to the forum you just can't get any help it takes weeks before you might get a reply







Donate to CBRT
User avatar
MDYoungblood
Verified
Site Admin
Site Admin
Posts: 10,421
Joined: June 12th, 2010, 8:05 pm
Age: 70
12

#409149

Post by MDYoungblood »

I don’t know a lot about the 25 models and not sure which one you are working on. Looking at a schematic of a GTL, it looks like C62 is just off pin 6 of the audio chip, like you I couldn’t find C168, I think that is in the 29 models. If the chip is getting extremely hot, that is telling me it is being over volted. My guess is the modulation limiter has been clipped or the transistor has gone bad.

3’s

Greg






"321, NW South Carolina"

Official Moderator - CBRT Complaint Department

Donate to CBRT
User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 420
Joined: June 26th, 2011, 6:05 pm
Age: 49
11

#409155

Post by smoke blower »

The final transistor was ad I pulled it out and tested it and it was shorted. As of now I put in a new one and the radio will key up but very little audio and the audio chip still gets very hot







Donate to CBRT
Post Reply Previous topicNext topic