Image

Cobra 148 UTB board and echo

Need some help with a radio mod? Pop in and ask away.

Moderator: JR Moderator

User avatar
MightyMo
Duckplucker
Duckplucker
Posts: 101
Joined: Thursday, 06 November 2014, 22:28 PM
Radio: Cobra 29 and 25
Name: Morgan

Cobra 148 UTB board and echo

Post by MightyMo » Thursday, 23 June 2016, 22:26 PM

I'm in the process of installing a Universal Talk Back board (UTB-1) and an echo board at the same time. I followed the instructions and refered to CB Radio Magazine's videos on the topic from youtube, but I have hit a snag. The echo board I'm using I got from 6 star on ebay, but I think it may be a Workman brand echo board. After I got it all hooked up, when I'd key the mic, I'd get a HORIBLE buzzing sound that wouldn't stop when I unkeyed the mic. I'd have to turn off the radio to get it to quit. Upon investigation I realized that the ground wire from the external speaker jack was the issue. The guy in the CB Radio Magazine grounded to a screw that mounts the main circuit board to the case. When I removed this wire and grounded it else where, the buzzing sound disappeared and talk back works.

THE PROBLEM

Now when I key the mic, talk back works, but NO ECHO. Also my receive disappears after releasing they mic and won't return unless I turn the radio off and on again. Any thoughts?

The echo board instructions had me remove the wire from the center terminal from the dynamic pot and solder that wire to the "in" wire and the "out"wire from the board was soldered onto the terminal instead. This makes sense to me, but is different than the CB Radio Magazine video which deals with the mic pins directly. Could this be a problem? Is there a chance I fried my finals or something with the UTB board being grounded improperly?


User avatar
443 Arizona
Wordwide & Qualified
Wordwide & Qualified
Posts: 644
Joined: Thursday, 29 April 2010, 13:22 PM
Radio: madison on 5/8 wave
Location: phoenix, arizona

Re: Cobra 148 UTB board and echo

Post by 443 Arizona » Tuesday, 18 April 2017, 11:59 AM

im going to throw out a wild guess and say your audio chip is not the one that allows your mod, to work. has anyone previously modded your radio?

User avatar
pabxone
Donor
Donor
Posts: 170
Joined: Friday, 01 May 2015, 23:54 PM
Radio: NDI PC201
Antenna: 1/2 wave vertical
Name: Mark Anderson
Location: Victoria , Australia

Re: Cobra 148 UTB board and echo

Post by pabxone » Tuesday, 18 April 2017, 17:09 PM

Just to be clear , you are installing 2 additional boards - A Talk Back board & an Echo board ?

"Also my receive disappears after releasing the mic and won't return unless I turn the radio off and on again." - That is a relay on one of the circuit boards holding stuck operated - when you power down the radio the relay is released until you key up the microphone again.

Something is wrong with the way you have wired these boards , we really need to know exactly what brand/type the boards are so we can see how they should be wired up.

Something else to consider :- Is your radio a 4 pin or 5 pin microphone socket Cobra 148 ?
The ground return paths on a 5 pin Cobra 148 are different to a 4 pin Cobra 148.
The ground line for the audio is separate from the ground line for the transmit / receive switching on the 5 pins.

Even using a 4 pin microphone with a 4 to 5 pin conversion microphone adaptor could be causing you problems here ?

User avatar
sonoma
Donor
Donor
Posts: 1294
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Cobra 148 UTB board and echo

Post by sonoma » Tuesday, 18 April 2017, 23:40 PM

pabxone is hitting on the right area. you are doing a 148 with 2 different grounds. I had the same problem and this is what 6 star sent me so I played with the grounds. you can leave either one of the grounds loose and tape one off and it should work. I left the ground off the main board that the wire ran with the 12 volt wire. either one left off should take car of your problem if you have the other wires hooked up right.

The only issue I have ever seen with the T3 is a ground problem once in a while. To solve this if you have a problem just Don't connect the shields of Input Output to ground and that seems to solve it. Thanks for your purchase and if you still want to return it no problem! Have a good weekend!

[ Post made via Linux Laptop ] Image

User avatar
MightyMo
Duckplucker
Duckplucker
Posts: 101
Joined: Thursday, 06 November 2014, 22:28 PM
Radio: Cobra 29 and 25
Name: Morgan

Re: Cobra 148 UTB board and echo

Post by MightyMo » Thursday, 18 May 2017, 17:12 PM

Wish I saw these replies sooner. My fault for not getting on.
Yes, 2 boards. Talkback board is UTB-1 and echo is T3 Echo Board.
My Radio: Cobra 148 gtl, front mic, 4 pin, made in China. Bought from Ham shop. They said I was second owner. As far as I can tell, no other mods done.

After this post, Talkback stopped working. I took the cb to a local CB shop. He told me I blew the audio chip in the talkback board because I grounded it wrong. He couldn't get a new chip so I got a new talkback board and proceeded on my own.

I reinstalled everything. The buzzing was no longer present, but the receive still wouldn't come back. Upon further investigation, I came across a website that indicated the relay on the Talkback board is prone to sticking due to a voltage issue. It suggested placing a 1N4148 diode on the PTT wire from the mic jack, but hooking up the green wire from UTB board before it so only the PTT wire would be affected by the diode. (http://cbworldinformer.com/rf_limited_u ... _board.htm) When I did that and tried it, It was better, but still not working right. The echo would only work as long as I kept the mic keyed. As soon as I released, the eco cut short. (I tried adjusting it all different ways). So I took the echo out and just tried the TalkBack board. Still had problems. Any suggestions?
(In the meantime, I've removed both boards and the radio is back to normal.)

I was doing some research on Schottkey diodes for the Cobra 29. I wonder if a Schottky diode in place of the 1N418 would make a difference. I just don't know much about diodes so I wouldn't know what value to get.

Thanks for your responses.


User avatar
MightyMo
Duckplucker
Duckplucker
Posts: 101
Joined: Thursday, 06 November 2014, 22:28 PM
Radio: Cobra 29 and 25
Name: Morgan

Re: Cobra 148 UTB board and echo

Post by MightyMo » Thursday, 18 May 2017, 17:14 PM

Dumb computer.... not sure how it submitted my response twice.

User avatar
MDYoungblood
Moderator
Moderator
Posts: 7173
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPhone
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD

Re: Cobra 148 UTB board and echo

Post by MDYoungblood » Friday, 19 May 2017, 15:15 PM

MightyMo wrote:
Thursday, 18 May 2017, 17:14 PM
Dumb computer.... not sure how it submitted my response twice.
No biggie, double posts give me something to do.

3's

Greg
ImageImageImage


"321, the Middle of Maryland"

23 AM "WORLD Image WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment


Base
Uniden Washington
Mobile
Texas Ranger TR-696FD1C
Handheld
Maxon HCB-40WX
Antennas
Avanti Sigma II
Homemade Full Wave Loop
Homemade 1/2 wave Dipole
Hustler 102" SS Whip and Hustler Ball Mount

Official Moderator - CBRT Complaint Department




Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 5 guests