Image

Yeticom Optima MK3 doesn't transmit

Have some other technical questions can't find the answer for? Come in and ask them here.

Moderator: JR Moderator

User avatar
stratotanker
4 PILL USER
4 PILL USER
Posts: 40
Joined: Saturday, 18 October 2014, 8:29 AM
Radio: Anytone Smart CB
Antenna: Sirio 5000
Name: Mr. 231 in the Carolinas

Yeticom Optima MK3 doesn't transmit

Post by stratotanker » Sunday, 19 March 2017, 13:01 PM

I have a Yeticom Optima MK3 that does not transmit at all.

When you key up the mic, there is no RF from the coax connector. This is in FM, AM or either one of the sidebands.

The radio does still receive.

The "TX" on the LCD lights up, but the bar graph at the bottom does not.

The cooling fan kicks on when keyed up.

But absolutely ZERO RF comes from the radio.

I even had a second radio next to it, tuned to the same channel, and it doesn't even pick up a signal.

Any ideas on why this radio is not producing RF? Where should I start looking?

The radio is maybe a year old and has spent 95% of it's time in my closet in its box. The one time I put it in my truck it worked, then quit working and hasn't worked ever since.

Thanks in advance.


User avatar
295 antenna
Mod Duck
Mod Duck
Posts: 582
Joined: Sunday, 23 October 2016, 21:45 PM
Radio: optima ,cobra 148ex
Antenna: patriot,brownig
Name: Charles Reney
Cell Phone: 760-672-1257

Re: Yeticom Optima MK3 doesn't transmit

Post by 295 antenna » Sunday, 19 March 2017, 16:48 PM

there is a way to reset it . its a pdf online
Keep smiling ...It makes people wonder what your up too !

American eagle member : AE1577
TWRC Member : WR2950



User avatar
295 antenna
Mod Duck
Mod Duck
Posts: 582
Joined: Sunday, 23 October 2016, 21:45 PM
Radio: optima ,cobra 148ex
Antenna: patriot,brownig
Name: Charles Reney
Cell Phone: 760-672-1257

Re: Yeticom Optima MK3 doesn't transmit

Post by 295 antenna » Sunday, 19 March 2017, 16:50 PM

Keep smiling ...It makes people wonder what your up too !

American eagle member : AE1577
TWRC Member : WR2950



User avatar
295 antenna
Mod Duck
Mod Duck
Posts: 582
Joined: Sunday, 23 October 2016, 21:45 PM
Radio: optima ,cobra 148ex
Antenna: patriot,brownig
Name: Charles Reney
Cell Phone: 760-672-1257

Re: Yeticom Optima MK3 doesn't transmit

Post by 295 antenna » Sunday, 19 March 2017, 16:52 PM

Im assuming you checked the rf gain and the squelch.(just checking) im as curious as you because i have that radio also
Keep smiling ...It makes people wonder what your up too !

American eagle member : AE1577
TWRC Member : WR2950



User avatar
MDYoungblood
Moderator
Moderator
Posts: 7402
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPad
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD
Contact:

Re: Yeticom Optima MK3 doesn't transmit

Post by MDYoungblood » Friday, 24 March 2017, 9:41 AM

I would say they are good SSB radios but with all electronics something can go wrong, your description makes it sound like the driver circuit is dead and that is quite possible if you used AM all the time. I would check the driver transistor and it's counterparts, if you don't have the equipment to do so a good shop should be able to get it up and running, basically it is a Magnum 257, just a couple items different inside, better IF section.

3's

Greg
"321, the Middle of Maryland"

23 AM "WORLD WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment



Official Moderator - CBRT Complaint Department




Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 1 guest