Image

Please Respond Need Help~

Have some other technical questions can't find the answer for? Come in and ask them here.

Moderator: JR Moderator

User avatar
Jarin
NEW DUCK
NEW DUCK
Posts: 1
Joined: Friday, 16 May 2008, 23:42 PM

Please Respond Need Help~

Post by Jarin » Friday, 16 May 2008, 23:50 PM

I have a midland weather max mini and every time i go to talk the person I'm talking to complains about only hearing a continuous beep until i let off the talk button (i know my CB knowledge is Laos i apologize) i have a magnet mount 18 inch whip and i have tried adjusting the squelch and hitting the analog button and just very confused and frustrated plz help me!


User avatar
Foxhunter
Donor
Donor
Posts: 2662
Joined: Thursday, 03 April 2008, 10:24 AM
Radio: Fisher-Price
Location: South-Central New Jersey
Referrals: 1

Re: Please Respond Need Help~

Post by Foxhunter » Friday, 16 May 2008, 23:57 PM

Jarin wrote:I have a midland weather max mini and every time i go to talk the person I'm talking to complains about only hearing a continuous beep until i let off the talk button (i know my CB knowledge is Laos i apologize) i have a magnet mount 18 inch whip and i have tried adjusting the squelch and hitting the analog button and just very confused and frustrated plz help me!
It could be a number of things but I might wonder first does your radio or mic have a "roger beep" function? One quick thing to start is to borrow one of your buddy's mic's and try using his on your radio and see if it eliminates the problem---you may have a bad mic. You're saying it's a "beeping" type sound, and not feedback or "squeal"?

I Remember


Image



User avatar
SUBWAY
4 PILL USER
4 PILL USER
Posts: 34
Joined: Thursday, 21 February 2008, 2:07 AM
Radio: loud & proud
Name: Jeran Goodwin
Location: Central Wisconsin

new mic

Post by SUBWAY » Saturday, 17 May 2008, 0:32 AM

I agree. I would first pic up a new mic preferably astatic 636- good noise cancelling mic. I have had bad experiences with
factory and cheap quality mics. Some have squelled some have sounded like I was in a tin can, some sounded like I was holding the mic out the window and trying to talk. the 636 ranges from 18-65 dollars depending where you get it.

User avatar
SmallTruckBigRadio
Donor
Donor
Posts: 2324
Joined: Friday, 17 February 2006, 21:14 PM
Radio: SWP / SR RCI 2950dx
Location: Cajun Transplanted To Indiana

Post by SmallTruckBigRadio » Tuesday, 07 October 2008, 6:49 AM

Antenna mounting, antenna connectors, antenna coax, and the possibility of a damaged antenna with high SWR could be something to check also.

What kind of vehicle? Where is the antenna mounted?
CB report card:
SWP SR RCI2950dx +TB +echo(A++)
SWP SR General Lee(A+) VarTB +10 pts
I've tried Galaxy 4 times (regretted every one)
DAVEMADE 3pill(A+) solid
FATBOY 3pill(A) almost a DaveMade
RK 56(A+) full sound, cords fail allot
Astatic 636L(A) best value, hold it against DaveMade!
Astatic D104M6(A) tinny, not noise cancelling
Shure 577b(A) only if you have a very hot radio, very low audio
SkyThumper ST-65DX(B) high energy, but junky sounding



User avatar
231
Site Admin
Site Admin
Posts: 7205
Joined: Friday, 13 January 2006, 15:19 PM
Radio: Uniden/Icom/Cobra
Location: Trudging the Pacific NW Trail
Referrals: 1

Post by 231 » Tuesday, 07 October 2008, 18:08 PM

SmallTruckBigRadio wrote:Antenna mounting, antenna connectors, antenna coax, and the possibility of a damaged antenna with high SWR could be something to check also.

What kind of vehicle? Where is the antenna mounted?
This would be my first thought as well. 18"? :shock: That would fall into the category of "rubby ducky." My guess is the reflection from it is so great it's getting back into the radio...either from the coax being bad, or the antenna itself. In any event, not sure I would waste alot of time on trying to use an 18" antenna. I'd surely replace that before I went any further if it were me.

Welcome to the forum. ;)


User avatar
the_junkie
Donor
Donor
Posts: 729
Joined: Wednesday, 17 September 2008, 19:23 PM
Radio: uniden pc68
Location: Illinois
Contact:

Post by the_junkie » Tuesday, 07 October 2008, 19:03 PM

I had a problem with squealing on the mic that came with my 19 ultra, when I put it on my 29. Funny thing is though, it still works fine for my buddy who is running it on my 19! but I would reccomend that you borrow a friend's mic, and also get yourself a better antenna. I like my firestick, but I also like the wilson 5k mag. It's not on my truck, but i still ike it ;) my only antenna advice--

DON'T BUY A TRUCKSPEC ANTENNA!!!

and good coax helps

but if it's the mic, like they said, go with a 636L!! They are amazing...sound/quality is great!!!
MOBILE:

1996 S-10 Pickup Truck
Aluminum Topper
200amp Leece-Neville
2 55-r4s
Cobra 29
1 pill Bull-It and 2 pill Bull-It
1x4 X-Force
5 Fighting Sticks
3 group 31 Batteries
PalStar PM2000am
All this = RELAY RELAY RELAY RELAY
" onclick="window.open(this.href);return false;



User avatar
Four
Skipshooter
Skipshooter
Posts: 207
Joined: Saturday, 30 August 2008, 14:42 PM
Radio: Galaxy dx33
Antenna: MM6
Name: Scott
Location: Alva Oklahoma
Contact:

Post by Four » Tuesday, 07 October 2008, 21:46 PM

2 ings i see could be your problem....
(1.) Try a different mic...could be shorting across the speaker itself causing the beeping sound... (ever heard a blown tweeter on a stereo?)

(2.) is this a cheap mag mount like wal mart sells?? if so..get rid of it..i tried and tried to get the swr's down on one of them cheap tangs..i couldnt get it done... if you wish to run a mag mount and be barefoot..i recommend looking into a wilson 1000...

good luck...


Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 2 guests