The CBRT/TWRC Convention
July 28 & 29, 2017

PS Question?

This is the place to ask questions about linear amplifiers, or power supplies

Moderator: JR Moderator

User avatar
Aughtry
Donor
Donor
Posts: 36
Joined: Wednesday, 25 January 2017, 19:21 PM
Radio: Galaxy DX959
Antenna: Predator 10K
Name: Ryan
Location: Prisontown, TX
Contact:

PS Question?

Post by Aughtry » Friday, 03 March 2017, 20:28 PM

I am in the process of replacing my mobile unit. It involves a great deal of upgrades. Power supply cable, Alternator, Battery, etc...It's costing me a good bit. I am looking at using my now old Galaxy DX959 and Palomar Elite 250 as a base. Yes, I realize that the antenna makes all the difference with a base. What I am looking for is an economical base power supply that can run the system. I look at PS's like Dave Made, FatBoy, and Xforce, but think that they are a bit much for the setup I'm looking at. Is there an economical option for running a small to medium amperage setup? I'm dropping thousands on my mobile. I need to find a way to reuse my galaxy with minimal money. Any assistance or advice would be very much appreciated from the folks here. I've learned everything I know about radio communications from here as it is...
Aughtry 7 double-deuce waivin' atcha from Prisontown, TX
Galaxy DX959, Astatic 636L, Palomar Elite 250, Predator 10K in the Mobile
Tex.Proud on IG




User avatar
sonoma
Donor
Donor
Posts: 1095
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: PS Question?

Post by sonoma » Friday, 03 March 2017, 21:09 PM

I would get a switching power supply for computers and other items of that type. you can get a 50 amp for about 30.00 and just hook it up. I have one I use and it is only about 30 amps and it works just fine. you can buy them that run from about 5 amps up to I know 50 amps and the price is very reasonable. I just checked at the one I have and it was 24.35 shipped to the house. it is a 30 amp.

User avatar
12voltpower
Sponsor
Sponsor
Posts: 12
Joined: Saturday, 30 October 2010, 14:16 PM
Name: John Marles
Contact:

Re: PS Question?

Post by 12voltpower » Thursday, 20 April 2017, 16:35 PM

Our MegaWatt S-700-12 50 amp supply should run it nicely.



User avatar
MDYoungblood
Moderator
Moderator
Posts: 6617
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPhone
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD

Re: PS Question?

Post by MDYoungblood » Thursday, 20 April 2017, 16:59 PM

12voltpower wrote:
Thursday, 20 April 2017, 16:35 PM
Our MegaWatt S-700-12 50 amp supply should run it nicely.
Here is the man that would know and our new forum sponsor, John aka "12voltpower".

3's

Greg
ImageImageImage

"321, the Middle of Maryland"

23 AM "WORLD Image WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment

Base
Uniden Washington
Mobile
Texas Ranger TR-696FD1C
Handheld
Maxon HCB-40WX
Antennas
Avanti Sigma II
Homemade Full Wave Loop
Homemade 1/2 wave Dipole
Hustler 102" SS Whip and Hustler Ball Mount

Official Moderator - CBRT Complaint Department



User avatar
12voltpower
Sponsor
Sponsor
Posts: 12
Joined: Saturday, 30 October 2010, 14:16 PM
Name: John Marles
Contact:

Re: PS Question?

Post by 12voltpower » Thursday, 20 April 2017, 20:36 PM

Even on SSB the radio and amp together should not draw more then 35 amps.




User avatar
jon6667
6 PILL USER
6 PILL USER
Posts: 98
Joined: Wednesday, 11 May 2016, 7:17 AM
Name: jon
Cell Phone: 5183353857

Re: PS Question?

Post by jon6667 » Friday, 21 April 2017, 11:07 AM

i have 3 of your ps. they all work great. the first one i bought was over 3 years ago. still runs great. i use it to power my kenwood

User avatar
12voltpower
Sponsor
Sponsor
Posts: 12
Joined: Saturday, 30 October 2010, 14:16 PM
Name: John Marles
Contact:

Re: PS Question?

Post by 12voltpower » Friday, 21 April 2017, 13:02 PM

jon6667 wrote:
Friday, 21 April 2017, 11:07 AM
i have 3 of your ps. they all work great. the first one i bought was over 3 years ago. still runs great. i use it to power my kenwood
I see 6 pill by your avatar. Are you running them in parallel?



User avatar
MDYoungblood
Moderator
Moderator
Posts: 6617
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPhone
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD

Re: PS Question?

Post by MDYoungblood » Friday, 21 April 2017, 13:22 PM

12voltpower wrote:
Friday, 21 April 2017, 13:02 PM
jon6667 wrote:
Friday, 21 April 2017, 11:07 AM
i have 3 of your ps. they all work great. the first one i bought was over 3 years ago. still runs great. i use it to power my kenwood
I see 6 pill by your avatar. Are you running them in parallel?
That is just a forum rating, the higher your post count gets the higher your rating becomes.

3's

Greg
ImageImageImage

"321, the Middle of Maryland"

23 AM "WORLD Image WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment

Base
Uniden Washington
Mobile
Texas Ranger TR-696FD1C
Handheld
Maxon HCB-40WX
Antennas
Avanti Sigma II
Homemade Full Wave Loop
Homemade 1/2 wave Dipole
Hustler 102" SS Whip and Hustler Ball Mount

Official Moderator - CBRT Complaint Department



User avatar
Aughtry
Donor
Donor
Posts: 36
Joined: Wednesday, 25 January 2017, 19:21 PM
Radio: Galaxy DX959
Antenna: Predator 10K
Name: Ryan
Location: Prisontown, TX
Contact:

Re: PS Question?

Post by Aughtry » Friday, 21 April 2017, 16:14 PM

Yeah, I noticed the new sponsorship yesterday. I'll check 'em out. I think my little palomar popped a transistor or something. Only getting half the usual power this afternoon when the DX actually came in round here. Need to look into that. Haven't seen any magic smoke, but performance was very poor. It's still in the mobile until my RCI arrives, and with the KEI alternator handling 186amps at idle, it's not a power issue. Need to pull it out and take a look this weekend.
Aughtry 7 double-deuce waivin' atcha from Prisontown, TX
Galaxy DX959, Astatic 636L, Palomar Elite 250, Predator 10K in the Mobile
Tex.Proud on IG



User avatar
jon6667
6 PILL USER
6 PILL USER
Posts: 98
Joined: Wednesday, 11 May 2016, 7:17 AM
Name: jon
Cell Phone: 5183353857

Re: PS Question?

Post by jon6667 » Saturday, 22 April 2017, 11:15 AM

no no amps here. just a 100 watt kenwood

User avatar
12voltpower
Sponsor
Sponsor
Posts: 12
Joined: Saturday, 30 October 2010, 14:16 PM
Name: John Marles
Contact:

Re: PS Question?

Post by 12voltpower » Saturday, 22 April 2017, 18:55 PM

jon6667 wrote:
Saturday, 22 April 2017, 11:15 AM
no no amps here. just a 100 watt kenwood
Ah come on. You need a 6 pill. :pirat:



User avatar
jon6667
6 PILL USER
6 PILL USER
Posts: 98
Joined: Wednesday, 11 May 2016, 7:17 AM
Name: jon
Cell Phone: 5183353857

Re: PS Question?

Post by jon6667 » Monday, 24 April 2017, 11:16 AM

nope i have a 12 tube maco. if need be. plugs in the wall.
but never needed it.


Post Reply Previous topicNext topic

Who is online

Users browsing this forum: Google [Bot] and 3 guests